DAMAS/MDD 2020 compliancy patch for LabManager 7.8

For users of LabManager 7.8, we thoroughly recommend upgrading to version 8.3.

LabManager 8.3 is DAMAS/MDD 2020 compliant and provides barcode printing, online ordering, and many other features not available in LabManager 7.8.

Please give our team a call on 0333 456 00 87 to discuss your available options for upgrading to version 8.3.

Alternatively, to obtain the DAMAS/MDD 2020 patch for LabManager 7.8, you must have a current LabManager 7.8 subscription or support cover.

If you have installed or updated to LabManager 7.8 after 14th January, 2020, then you will already have the DAMAS/MDD features.

For other 7.8 users, our support team may have already installed the compliancy patch for you if you have discussed this with them.

If you require the patch, please use the contact form to request it.